Foro especializado en Warcraft III y su editor
 
BuscarEntrar al ChatboxPortal del foroÍndiceSpellsRegistrarseConectarseGrupos de Usuarios
Eventos Actuales
¡ Bienvenido Invitado !

Editar Perfil

Tus temas
Tus Mensajes ()

Enlaces rápidos








Comparte | .
 

 Lag causado por múltiples unidades con De-buffos

Ver el tema anterior Ver el tema siguiente Ir abajo 
AutorMensaje
LycanFallen
Peón
avatar


Barra de Salud : Su salud está al 100% - Este usuario no ha recibido infracciones

Mensajes Mensajes : 33
Reputación Reputación : 0
Monedas de oro : 174
Monedas de Platino : 0

Inventario :



Mensaje(#) Tema: Lag causado por múltiples unidades con De-buffos Sáb Mayo 19, 2018 8:23 pm

Hola, verán, hace un tiempo pregunte esto pero creí que era causado ya que estaba usando items para aplicar los debuffos, me recomendaron un ''Item cleaner''. El problema es que eso no era lo que causaba el lag, ya que ahora hice que un edificio aplicara la habilidad ''Quemar alma'' a determinadas unidades y esto causa lag una vez empieza a haber unas 10 XD (lo mismo pasaba cuando usaba los items)
Me gustaría saber que puedo hacer para que esto no pase :s u otra forma de lograr aplicarles un debuff de reducción de daño y velocidad de ataque

Gracias de antemano xD


''Soy Nostro y mi alma es la de un guerrero''
Volver arriba Ir abajo
Marcos_M

avatar


Barra de Salud : Su salud está al 100% - Este usuario no ha recibido infracciones

Mensajes Mensajes : 3115
Reputación Reputación : 522
Monedas de oro : 9646
Monedas de Platino : 0

Inventario :



Mensaje(#) Tema: Re: Lag causado por múltiples unidades con De-buffos Sáb Mayo 19, 2018 8:34 pm

Posiblemente el problema no sea el buffo sino tus detonadores. Podrías mostrarlos?
Volver arriba Ir abajo
LycanFallen
Peón
avatar


Barra de Salud : Su salud está al 100% - Este usuario no ha recibido infracciones

Mensajes Mensajes : 33
Reputación Reputación : 0
Monedas de oro : 174
Monedas de Platino : 0

Inventario :



Mensaje(#) Tema: Re: Lag causado por múltiples unidades con De-buffos Sáb Mayo 19, 2018 10:21 pm

Pense eso, pero no, también intente aplicar yo mismo el debuff a varias unidades y de igual forma se lageaba, usando o no un detonador para hacerlo, el lag se produce igual.



''Soy Nostro y mi alma es la de un guerrero''
Volver arriba Ir abajo
PENSATIVO197
Aprendiz
avatar


Barra de Salud : Su salud está al 100% - Este usuario no ha recibido infracciones

Mensajes Mensajes : 25
Reputación Reputación : 3
Monedas de oro : 68
Monedas de Platino : 0

Inventario :



Mensaje(#) Tema: Re: Lag causado por múltiples unidades con De-buffos Sáb Mayo 19, 2018 10:59 pm

creo q si quieres una habilidad q kite daño, puedes usar "Lisiar" de los muertos vivientes... y si es en AOE, el "Aullido del Terror" de ese Heroe del pit lord de la campaña q kita ataque, si quieres con silence yaeso noma...
Volver arriba Ir abajo
Marcos_M

avatar


Barra de Salud : Su salud está al 100% - Este usuario no ha recibido infracciones

Mensajes Mensajes : 3115
Reputación Reputación : 522
Monedas de oro : 9646
Monedas de Platino : 0

Inventario :



Mensaje(#) Tema: Re: Lag causado por múltiples unidades con De-buffos Dom Mayo 20, 2018 10:49 am

Si se produce lag por un debuff, lo más probable es que el efecto genera muchas partículas por alguna razón, trata cambiando o eliminando el modelo
Volver arriba Ir abajo
LycanFallen
Peón
avatar


Barra de Salud : Su salud está al 100% - Este usuario no ha recibido infracciones

Mensajes Mensajes : 33
Reputación Reputación : 0
Monedas de oro : 174
Monedas de Platino : 0

Inventario :



Mensaje(#) Tema: Re: Lag causado por múltiples unidades con De-buffos Dom Mayo 20, 2018 1:17 pm

Pense en eso cuando vi el lag, así que le retire todos los efectos.
Sea como sea, ya se arreglo, aparentemente, la habilidad de ''Quemar alma'' que use de base para esta necesita tener si o si su valor de ''Periodo de daño'' el cual yo había reducido a 0, ahora que lo re establecí a 1 el lag ya no se produce Very Happy (no entiendo porque esto es así, pero ya que, almeno se arreglo)


Gracias de todas formas por las respuestas.


''Soy Nostro y mi alma es la de un guerrero''
Volver arriba Ir abajo
Marcos_M

avatar


Barra de Salud : Su salud está al 100% - Este usuario no ha recibido infracciones

Mensajes Mensajes : 3115
Reputación Reputación : 522
Monedas de oro : 9646
Monedas de Platino : 0

Inventario :



Mensaje(#) Tema: Re: Lag causado por múltiples unidades con De-buffos Dom Mayo 20, 2018 7:52 pm

Ahhh, eso es porque si pones Periodo de daño "0.00" el juego le hará daño a la unidad cada 0.00 segundos, esto generalmente no laguea, porque la unidad es matada instantáneamente, pero si pones daño 0, esto no puede matar pero el juego aún así hace 0 de daño a la unidad(Sí, el juego hace estas cosas), entonces tienes el juego causando daño a una unidad cada vez que el procesador se lo permite, entonces fuerzas al juego al límite con una acción que virtualmente ocurre infinitas veces en 0.01 segundos.

Comprendes la razón?
Volver arriba Ir abajo
PENSATIVO197
Aprendiz
avatar


Barra de Salud : Su salud está al 100% - Este usuario no ha recibido infracciones

Mensajes Mensajes : 25
Reputación Reputación : 3
Monedas de oro : 68
Monedas de Platino : 0

Inventario :



Mensaje(#) Tema: Re: Lag causado por múltiples unidades con De-buffos Lun Mayo 21, 2018 4:32 am

cierto, a mi me pasaba ese lag y hasta tme tiiraba error a la bomba acida de campaña... esa que kita armadura, rebota y reduce velocidad...
Volver arriba Ir abajo
Contenido patrocinado




Mensaje(#) Tema: Re: Lag causado por múltiples unidades con De-buffos

Volver arriba Ir abajo
 

Lag causado por múltiples unidades con De-buffos

Ver el tema anterior Ver el tema siguiente Volver arriba 
Página 1 de 1.

 Temas similares

-
» [MOD Civilization IV] Fall From Heaven 2
» Empire Total War & Napoleon Total War: Game of the Year Edition
» [014] [VOTACIÓN] Ley de cesión de ORGs a partidos y unidades militares - Madridista1991 en nombre de Edahi[eCiudadano]
» Iconos para Divisiones/unidades/etc

Permisos de este foro:No puedes responder a temas en este foro.
Warcraft III - WorldEditor :: Zona de Aprendizaje(Dudas) :: GUI (Detonadores)-